Please note, we also rely on the following vendors:

Cloudflare: https://www.cloudflarestatus.com
Microsoft Azure: https://azure.status.microsoft/en-gb/status
Postmark: https://status.postmarkapp.com/
Sendgrid: https://status.sendgrid.com/

Apple is blocking emails to @me.com and @icloud.com addresses

Minor incident Order processing Drop-in checkout Hosted checkout
2021-09-15 09:01 BST · 1 day, 2 hours, 5 minutes

Updates

Resolved

This has now been resolved and mail is now being sent to @me.com and @icloud.com addresses

November 4, 2021 · 15:25 BST
Investigating

We have received reports of emails being blocked for Apple’s domains.

We are liaising with Apple to get this sorted as soon as possible.

November 4, 2021 · 15:25 BST

← Back