Please note, we also rely on the following vendors:

Cloudflare: https://www.cloudflarestatus.com
Microsoft Azure: https://azure.status.microsoft/en-gb/status
Postmark: https://status.postmarkapp.com/
Sendgrid: https://status.sendgrid.com/

Intermitent Dashboard Access

Minor incident Dashboard UK 1 Dashboard UK 2 Dashboard
2025-11-25 11:45 GMT · 1 hour, 35 minutes

Updates

Resolved

We’ve managed to resolve this issue.

November 25, 2025 · 13:19 GMT
Update

Issue identified, a fix is being deployed now.

November 25, 2025 · 12:47 GMT
Investigating

We have received reports that the Gift Up dashboard is intermittently failing to load.

It looks like Microsoft Azure are having routing issues in the UK, we are actively monitoring and working to mitigate the issue.

November 25, 2025 · 12:07 GMT

← Back