Please note, we also rely on the following vendors:

Cloudflare: https://www.cloudflarestatus.com
Microsoft Azure: https://azure.status.microsoft/en-gb/status
Postmark: https://status.postmarkapp.com/
Sendgrid: https://status.sendgrid.com/

Azure Routing Issue

Major incident Dashboard UK 1 Dashboard UK 2 Dashboard US 1 Dashboard AU 1 Dashboard API UK 1 API UK 2 API US 1 API AU 1 API API docs Order processing Drop-in checkout Hosted checkout Email processing Inbound webhooks
2025-10-29 15:44 GMT · 15 hours, 46 minutes

Updates

Resolved

It appears that Microsoft have resolved the issue.
All mitigation has been removed, and we are back to our usual infrastructure.

October 30, 2025 · 07:29 GMT
Monitoring

Microsoft are still in the process of resolving this issue, so we continue in a mitigated state.

October 29, 2025 · 22:45 GMT
Update

We believe we’ve managed to work around most if not all issues presented by the Microsoft Front Door outage.

We are still waiting a resolution from Microsoft, and there’s little more we can do now.

October 29, 2025 · 18:01 GMT
Monitoring

It looks like Microsoft Azure are having major issues with their routing platform again.

We have mitigated the issue, and will continue monitoring.

October 29, 2025 · 16:08 GMT

← Back