Please note, we also rely on the following vendors:

Cloudflare: https://www.cloudflarestatus.com
Microsoft Azure: https://azure.status.microsoft/en-gb/status
Postmark: https://status.postmarkapp.com/
Sendgrid: https://status.sendgrid.com/

Order processing delayed

Minor incident Inbound webhooks
2020-07-09 18:49 BST · 2 hours, 43 minutes

Updates

Resolved

All pending orders have now been processed

November 4, 2021 · 15:24 BST
Investigating

The root cause has been identified and order are being processed again with no latency. All existing, unprocessed orders are being processed now.

November 4, 2021 · 15:24 BST
Issue

We are experiencing some orders not being processed in a timely fashion. We are investigating.

November 4, 2021 · 15:24 BST

← Back