Please note, we also rely on the following vendors:

Cloudflare: https://www.cloudflarestatus.com
Microsoft Azure: https://azure.status.microsoft/en-gb/status
Postmark: https://status.postmarkapp.com/
Sendgrid: https://status.sendgrid.com/

Microsoft/Office 365 Email Delivery

Minor incident Dashboard
2020-05-14 12:00 BST · 1 month, 1 week

Updates

Monitoring

Our emails appear to be occasionally landing in the Junk Email folder. Only notification & invite emails are affected.

November 4, 2021 · 15:24 BST
Issue

We are experiencing temporary issues getting emails delivered to your inbox at the moment. The issue has been reported to Microsoft and gift card emails are unaffected. Please visit your SPAM/junk folder and in the Office 365 Quarantine and please mark the emails as not spam to get them delivered to your inbox.

November 4, 2021 · 15:24 BST

← Back